Browse Source

Revert flow config

This prevented flow from starting so I had to reset it.
Arnaud Vergnet 1 year ago
parent
commit
05ef28f3b5
1 changed files with 0 additions and 73 deletions
  1. 0
    73
      .flowconfig

+ 0
- 73
.flowconfig View File

@@ -1,73 +0,0 @@
1
-[ignore]
2
-; We fork some components by platform
3
-.*/*[.]android.js
4
-
5
-; Ignore "BUCK" generated dirs
6
-<PROJECT_ROOT>/\.buckd/
7
-
8
-; Ignore polyfills
9
-node_modules/react-native/Libraries/polyfills/.*
10
-
11
-; These should not be required directly
12
-; require from fbjs/lib instead: require('fbjs/lib/warning')
13
-node_modules/warning/.*
14
-
15
-; Flow doesn't support platforms
16
-.*/Libraries/Utilities/LoadingView.js
17
-
18
-[untyped]
19
-.*/node_modules/@react-native-community/cli/.*/.*
20
-
21
-[include]
22
-
23
-[libs]
24
-node_modules/react-native/interface.js
25
-node_modules/react-native/flow/
26
-
27
-[options]
28
-emoji=true
29
-
30
-esproposal.optional_chaining=enable
31
-esproposal.nullish_coalescing=enable
32
-
33
-module.file_ext=.js
34
-module.file_ext=.json
35
-module.file_ext=.ios.js
36
-
37
-munge_underscores=true
38
-
39
-module.name_mapper='^react-native/\(.*\)$' -> '<PROJECT_ROOT>/node_modules/react-native/\1'
40
-module.name_mapper='^@?[./a-zA-Z0-9$_-]+\.\(bmp\|gif\|jpg\|jpeg\|png\|psd\|svg\|webp\|m4v\|mov\|mp4\|mpeg\|mpg\|webm\|aac\|aiff\|caf\|m4a\|mp3\|wav\|html\|pdf\)$' -> '<PROJECT_ROOT>/node_modules/react-native/Libraries/Image/RelativeImageStub'
41
-
42
-suppress_type=$FlowIssue
43
-suppress_type=$FlowFixMe
44
-suppress_type=$FlowFixMeProps
45
-suppress_type=$FlowFixMeState
46
-
47
-suppress_comment=\\(.\\|\n\\)*\\$FlowFixMe\\($\\|[^(]\\|(\\(<VERSION>\\)? *\\(site=[a-z,_]*react_native\\(_ios\\)?_\\(oss\\|fb\\)[a-z,_]*\\)?)\\)
48
-suppress_comment=\\(.\\|\n\\)*\\$FlowIssue\\((\\(<VERSION>\\)? *\\(site=[a-z,_]*react_native\\(_ios\\)?_\\(oss\\|fb\\)[a-z,_]*\\)?)\\)?:? #[0-9]+
49
-suppress_comment=\\(.\\|\n\\)*\\$FlowExpectedError
50
-
51
-[lints]
52
-sketchy-null-number=warn
53
-sketchy-null-mixed=warn
54
-sketchy-number=warn
55
-untyped-type-import=warn
56
-nonstrict-import=warn
57
-deprecated-type=warn
58
-unsafe-getters-setters=warn
59
-unnecessary-invariant=warn
60
-signature-verification-failure=warn
61
-deprecated-utility=error
62
-
63
-[strict]
64
-deprecated-type
65
-nonstrict-import
66
-sketchy-null
67
-unclear-type
68
-unsafe-getters-setters
69
-untyped-import
70
-untyped-type-import
71
-
72
-[version]
73
-^0.122.0

Loading…
Cancel
Save